www.belgium.be Logo of the federal government

VULNÉRABILITÉ D'EXÉCUTION DE CODE MALVEILLANT À DISTANCE DÉCOUVERTE POUR EXIM MTA

Référence: 
Advisory #2019-023
Version: 
1.0
Logiciels concernés : 
Exim (versions <= version 4.92.2)
Type: 
VULNÉRABILITÉ D'EXÉCUTION DE CODE MALVEILLANT À DISTANCE
CVE/CVSS: 

CVE-2019-16928

Sources

https://www.bleepingcomputer.com/news/security/new-exim-vulnerability-exposes-servers-to-dos-attacks-rce-risks/

https://www.exim.org/static/doc/security/CVE-2019-16928.txt

Risques

Un attaquant (local ou distant) peut exécuter du code arbitraire avec les privilèges root, ce qui peut compromettre l'intégrité du système/des données, la confidentialité et/ou la disponibilité. Nous avons vu une large exploitation de la vulnérabilité Exim dès septembre, nous pouvons donc nous attendre à une large exploitation de cette vulnérabilté à très court terme.  

Description

Exim, un MTA (agent de transfert de courrier) fort/très répandu contient une vulnérabilité grave permettant à un attaquant d'exploiter un débordement de zone tampon sur le tas (heap-based buffer overflow) qui pourrait amener sur une exécution de code arbitraire à distance. Normalement Exim aurait laissé tomber ses privilèges root à ce point de l'exploitation de la vulnérabilité mais, couplée à un exploit d'escalade de privilèges, cet exploitation d'exécution de code à distance en tant que root est tout à fait faisable. 

Actions recommandées

Le CERT.be recommande aux administrateurs systèmes de mettre à jour leur systèmes Exim avec diligence.